Not about everything

March 12, 2014

The horrors of upgrading to Windows7

Filed under: windows — takaita @ 09:08

Windows XP is going to be obsolete. Banks threaten that it can not be longer used for internet banking. Microsoft and everyone else is sending out warning signs. What else can a poor boy do then upgrade. I decided to upgrade to Windows7, ordered a official copy and read the Microsoft instructions.

It seemed to easy. Dowload and install Windows Easy Transfer, run it, do a custom install of Windows7 and then import the stuff again from the file created by Windows Easy Transfer.

My advice: do not use Windows Easy Transfer, as it only breaks stuff. Think for yourself what you want to save, and do it manually. Microsoft has created a monster with Windows Easy Transfer, giving you hours of work extra.

Here is my story. I did as Microsoft suggested. First thing was that Windows Easy Transfer wanted to “transfer” all my photos with I have stored on my D: disk. That is not trivial, because I own a DSLR and I have Gigabytes of photos. Of course Windows Easy Transfer did not “know” that I wanted to upgrade on the same machine. There is no need to transfer files from D: as they are supposed to stay untouched. Windows Easy Transfer could have asked. On the first try I let it run by default, until I noticed it was trying to pack 250 GB of photos which would take about 15 hours. There is no “cancel”button, but it possible to stop the process by quitting the program. Fine. Next time I made sure it was just packing the user profiles.

After a custom install of Windows7, I did again as suggested: import from the file created by Windows Easy Transfer. Did not work. It said that was because my new Windows was of a different language then the previous. Yes, that is right. I went from English to Dutch, because I now have kids who can not read English, and they will be users too. I used to prefer English, because Windows error messages in a non-English language are hard to find documentation about.

So. That left me with unimported accounts. I decided to create the accounts manually. My wife is called Eva, and had an account with that name. So I created a new account with that name. Tried to create. I get an error message that I can not create that account, because I can not use the characters /\[]”:;|+=,?*. Litterally it said in Dutch: “De opgegeven accountnaam is ongeldig, omdat accountnamen de volgende tekens niet mogen bevatten: /\[]”:;|+=,?*”.

That left me flabbergasted. I was not using any of those characters, so the error message makes no sense at all. Searching on the (Dutch) error message gave some results, but no solution – as I feared. I tried to translate it into English and search for that. That gave results which pointed me in the right direction. It turned out that it might happen after a unsuccessful effort to import settings from Windows Easy Transfer. What actually happened was that the accounts were imported but were hidden. They showed up at the command prompt with “c:> net user”, but they were not visible in the users list in the configuration panel and they were not visible on the login screen.

Next suggestion was that they can be made visible by running the command prompt as admninistrator and then type this: “net user Eva /active:yes”. I tried that, and it succeeded but the user account was still invisible. Then I decided to take a look at the account specs and noticed that it was not a member of any group. That can be solved to from the command prompt: “net localgroup Gebruikers Eva /add”, which adds the account Eva to the loca group “Gebruikers”. And only after that the account showed up.

So I had my accounts back. Only their settings were not there. I am not so bad with computers, so I wanted to restore some setting manually from the old profiles. But then it turned out that those were gone. The “Documents and Setting” directory had been deleted. Either by Windows7 install or by Windows Easy Transfer. That is quite shitty. Now I found a way to open the file created by Windows Easy Transfer and could partially restore the “Documents and Setting” directory from there. The file is called MigViewer and I downloaded it from here.

So. Windows Easy Transfer did not transfer anything, except creating hidden accounts which caused an obscure error message when trying to manually create these accounts. I took me some hours to find out. Then it (or Windows7 install) deleted the old settings from the “Documents and Setting” folder, which makes it extra hard to recover user settings.

I am still working on getting things right.

Advertisements

Leave a Comment »

No comments yet.

RSS feed for comments on this post. TrackBack URI

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

Create a free website or blog at WordPress.com.

%d bloggers like this: